[RE-OPENED] Boarded Horses are Missing from Boarding Page

Description of Issue
Affected horses are, to my knowledge, just Sonic Command and Chimney Swift. This happened when I was ending boarding for some my horses. I clicked (or, potentially double clicked) the Leave Boarding Farm button on the boarding page. When I refreshed Training Summary page in another tab, it shows both horses as still being at the boarding farm (but the number of days they’ve been there has been reset), but I don’t see them as an option on the boarding page --either from the dropdown list or from the table. This leads me to believe that they’re simultaneously both at the boarding barn and at the track.

Steps to Reproduce

Occasionally, when I click the “Leave Boarding Farm” button, nothing will happen – the horse won’t disappear from the boarded horse table. So, you then have the opportunity to click the button again, and then the bug should appear.

Additional information
I’m curious to see if I could fix this on my end by shipping them somewhere, but that’s really only academic curiousity.

Just to follow up on this, I tried shipping Sonic Command from Gulfstream to Calder. According to the Training Summary page, he checked himself right into the Calder Boarding Farm rather than the track.

Twist of Fate, Seduction, and Chimney Swift are stuck at the boarding barn. Would you mind sending them to the track, please?


I also tried to replicate the issue with my barn and couldn’t yet…could you let me know when you board the more buggy horses again and I can play with them when you’re ready to stop boarding?

Thank you! There was a window of time where the boarding page was buggy, which is when they first got stuck at the boarding farm. I haven’t noticed it recently (i.e. no horses have gotten stuck within the past 3-4 weeks), so I think it’s resolved. These ponies were just residually stuck. I’ll ping you if I notice it happening again.

Unfortunately, this appears to be broken again.

Despacito is stuck at the boarding farm. On the stable summary page, I see him listed at Belmont Boarding Farm(). On his page, it says “Belmont Boarding Farm (NY, USA) - Boarded For 0 Days”, even though he’s been boarded since 6/12. However, on the boarding page, he’s not listed, so I can’t send him to the track.

I’m still not sure why this is happening, but I’ve added a query to the daily update script that should un-stick horses.

No worries! My hunch is that it’s some sort of browser interaction. I generally know before I check which horses have failed to go home…

I will be on the boarded horses page, click the button to send the horse home and it won’t disappear from the page like it normally does. If I click the button again, the horse disappears…but then you check the stable training summary page and it becomes clear that the horse never made it home. It seems to happen in both FF and Chrome…so maybe not a browser interaction.

Not sure if that helps at all…